pt.phhsnews.com


pt.phhsnews.com / Como verificar se suas extensões vão parar de funcionar com o Firefox 57

Como verificar se suas extensões vão parar de funcionar com o Firefox 57


Com o Firefox 57, com lançamento previsto para 14 de novembro de 2017, a Mozilla encerrará o suporte a extensões herdadas e só suportará WebExtensions mais recentes . Veja como verificar se suas extensões deixarão de funcionar e como continuar usando-as depois de novembro, se necessário.

Por que as extensões XUL estão indo embora

Todas as extensões tradicionais, incluindo as extensões XUL, estão sendo descontinuadas. Eles eram muito poderosos, mas isso era tanto uma força quanto uma fraqueza. O enorme poder dessas extensões significava que eles poderiam modificar o código do navegador do Firefox, o que poderia levar a instabilidade e add-ons de malware aparentemente inocentes.

Em vez disso, a Mozilla trabalhou em WebExtensions, que são semelhantes aos complementos do Chrome e Edge . Este é o futuro das extensões do Firefox. Como esses complementos precisam funcionar de maneira mais padronizada e não podem mexer no código interno do Firefox, eles devem causar menos problemas. Também deve ser mais fácil para os desenvolvedores portarem complementos do Chrome para o Firefox.

Atualmente, o Firefox suporta extensões tradicionais (legadas) e extensões Web. Com o Firefox 57, as extensões mais antigas deixarão de funcionar e apenas WebExtensions mais recentes funcionarão. Essa mudança já está no Firefox Nightly, a versão de desenvolvimento de ponta do Firefox. Os desenvolvedores foram levados a atualizar suas extensões, mas nem todas têm, o que nos leva ao problema

Como ver se suas extensões deixarão de funcionar

se você usar o Firefox hoje, pode verificar quais de seus as extensões deixarão de funcionar na versão 57. Para verificar, clique em menu> Complementos e selecione a categoria “Extensões”.

Extensões mais antigas que deixarão de funcionar são rotuladas com uma etiqueta “Legado” se você estiver usando o Firefox 55 ou mais recente. Modern WebExtensions que continuarão funcionando aparecem normalmente

Como procurar por novas extensões

Se uma extensão tiver a tag “Legacy”, você pode verificar essa lista de extensões populares com informações sobre o status da atualização. Por exemplo, na captura de tela acima, LastPass é marcado como extensão Legacy que irá parar de funcionar, mas podemos ver que os desenvolvedores planejam substituí-lo por um WebExtension antes da data de lançamento do Firefox 57.

Para extensões menos populares, você pode precisar para realizar uma pesquisa na web para ver se o desenvolvedor está planejando uma atualização. Os desenvolvedores precisam portar suas extensões para WebExtensions, e nem todos os desenvolvedores farão isso

Se uma extensão da qual você depende parar de funcionar, talvez seja necessário procurar uma alternativa moderna que faça algo semelhante. Você pode procurar apenas complementos que sejam compatíveis com o Firefox 57 ou mais recente no site dos Complementos da Mozilla.

Qualquer complemento que tenha a tag “Compatível com o Firefox 57+” é um WebExtension que continuará funcionando. Por exemplo, a extensão do User Agent Switcher que nós instalamos não está planejada para uma atualização, então provavelmente nós queremos instalar uma das mais modernas extensões do User Agent Switcher.

RELACIONADAS: As extensões do navegador são um pesadelo de privacidade: Pare de usar tantos deles

Este é um bom momento para avaliar se você realmente precisa de todas essas extensões, no entanto. As extensões do navegador podem ser perigosas, por isso é uma boa ideia instalá-las apenas se forem realmente úteis para você e de uma fonte confiável.

Como continuar usando extensões herdadas

Se você realmente precisar de uma extensão antiga, Há uma maneira de continuar usando-as com segurança. Mude para o Firefox Extended Support Release, também conhecido como Firefox ESR. Esta é uma versão mais lenta do Firefox destinada em grande parte para empresas que não querem grandes atualizações de recursos a cada seis semanas.

A versão atual do Firefox ESR é baseada no Firefox 52 e será suportada com atualizações de segurança até 26 de junho de 2018 Como é baseado no Firefox 52, as extensões mais antigas continuarão funcionando sem nenhum problema

Depois de 26 de junho de 2018, você terá que atualizar para versões mais recentes do Firefox ESR que não suportarão mais as extensões legadas se você quiser continue recebendo atualizações de segurança. Esta não é uma solução permanente, mas é uma boa maneira de continuar usando suas extensões atuais por mais sete meses enquanto avalia alternativas mais modernas.


Como restaurar o Firefox às suas configurações padrão e iniciar o Fresh

Como restaurar o Firefox às suas configurações padrão e iniciar o Fresh

Qualquer navegador pode ficar lento e ficar sobrecarregado ao instalar plug-ins, criar histórico e alterar configurações. O Firefox pode “atualizar” o seu perfil para fornecer rapidamente um quadro limpo, mantendo os dados mais importantes. Isso permitiria que você experimentasse o Firefox Quantum com um novo perfil, apressasse o Firefox se ele se tornasse lento ou corrigisse outros problemas do navegador.

(how-top)

Por que o meu iPhone exibe

Por que o meu iPhone exibe "Recomendação de segurança" para uma rede Wi-Fi?

Quando você se conecta a uma rede Wi-Fi no iPhone, pode ver as palavras "Recomendação de segurança" aparecem abaixo do seu nome. Este é um aviso de que você está conectado a uma rede desprotegida ou criptografada com segurança WEP fraca. Redes inseguras e segurança fraca Se você tocar no nome da rede Wi-Fi exibindo “Recomendação de segurança” uma vez Se você estiver conectado a ele, verá uma mensagem mais informativa.

(how-top)